First off you will need to configure the vlan’s to be routed on the network router. This example will use a Cisco 3750G Layer 3 Switch as a Router.

router> en

router# config t

router(config)# vlan 100

router(config-vlan)# name AccountingVLAN

router(config-vlan)# exit

router(config)# interface vlan 100

router(config-if)# ip address 192.168.50.1 255.255.255.0 <—Default gateway of your VLAN

router(config-if)# des Accounting VLAN Gateway

router(config-if)# exit

router(config)# int gi1/0/24

router(config-if)# switchport trunk encap dot1q

router(config-if)# switchport mode trunk

router(config-if)# switchport trunk allowed vlan 100

router(config-if)# des  Uplink to switch

router(config-if)# CTRL-Z

router# wr mem


Now we need to configure the VLAN access ports on the switch trunking VLAN 100. Cisco 3750G switch.

switch> en

switch# config t

switch(config)# vlan 100

switch(config-vlan)# name AccountingVLAN

switch(config-vlan)# exit

switch(config) # int gi1/0/24

switch(config-if) # switchport trunk encap dot1q

switch(config-if)# switchport mode trunk

switch(config-if)# switchport trunk allowed vlan 100

switch(config-if)# des Uplink to router

switch(config-if)# CTRL-Z

switch# wr mem

By Tim